WinSales 5.0 Release Notes

Revision Date: 12/28/2001

Support Document: sup054
These release notes are meant to assist existing WinSales users in converting their present installation of WinSales to 5.0.  This has been broken up into separate modules for ease of finding information regarding areas of the program.

WinSales 5.0 System Requirements

Hardware requirements and recommendations: To install WinSales 5.0 you must have at least 25mb of free space on the hard drive.  The minimum machine requirements are a p200 with 64mb of RAM.  We recommend p450 or higher with at least 128mb of RAM.  

Windows 95 requires Outlook 2000: To install WinSales 5.0 on a Windows 95 machine Outlook 2000 must be installed. 
Microsoft Data Access Control (MDAC) requirements: WinSales 5.0 will force the installation of MDAC v2.6 and Jet 4, which requires Microsoft Internet Explorer 4.01 service pack 2 or greater.  If users are not currently running IE 4.01 service pack 2 they will be forced to upgrade before installing WinSales 5.0.  Users working with NT 4.0 will need to have at least service pack 5 installed to run the v2.6 of MDAC. To download MDAC v2.6 go to: http://www.microsoft.com/Data/download_26sp1.htm
Windows 95/98/ME: WinSales 5.0 will install Dcom98. Dcom98 can be downloaded from http://windowsupdate.microsoft.com/.
Windows 2000 users will be required to have Service Pack 1, however we strongly recommend Service Pack 2, which can be downloaded from www.microsoft.com.

Windows XP & 2000 users installing WinSales 5.0 only installs the program for the profile of the user logged on to the machine. Other user profiles will also need to install WinSales 5.0.

Internet Explorer 5.0 is required for support of WinSales 5.0 features linking to Internet Explorer. Silent Partner strongly recommends Internet Explorer 5.5, which can be downloaded from http://windowsupdate.microsoft.com.
Mail Merge with Microsoft Word requires Microsoft Word 97/2000/XP.

Windows 2000 Terminal Server will work with WinSales with the removal of the WINSALES.INI file and the local message files in the 5.0 version.  For more information on Terminal Server see www.microsoft.com.
SQL Server 7.0 and 2000 are supported with WinSales 5.0.  For more information on SQL Server see www.microsoft.com.  For details on converting your WinSales 4.0 or 5.0 database to SQL server see your CD or www.silentpartner.com for WS 5.0 SQL Conversion Instructions.doc.

WinSales 5.0 Database Conversion Program

For detailed information and instructions on converting your WinSales 3.x or 4.0 database to WinSales 5.0 see the WinSales 5.0 Conversion Instructions.doc on your CD or at www.silentpartner.com.  

The conversion program creates a WinSales 5.0 database with an evaluation license, contact Silent Partner for re-licensing of your database.  See further details on licensing in WinSales 5.0 in the Release Notes section on the WinSales Administrator, or check www.silentpartner.com for support documents on licensing.
The conversion program requires you log into the database as a valid WinSales user (with password if appropriate) to run the conversion program.
The conversion the program will evaluate all table names to check if any are reserved words, if any are found you will be prompted to run the Table Rename program to rename the table to something that is not a reserved word.  See the WinSales 5.0 Conversion Instructions.doc and WinSales 5.0 Table Rename Utility.doc for more information on reserved words in the conversion to WinSales 5.0.

The conversion the program will check table records for duplicate ID’s and if any are found the conversion program will be stopped and the message displayed will indicate what TABLE the duplicate ID exists in, and what the ID is.  Users will need to open the database using Microsoft Access (or SQL Server Enterprise Manager if converting a SQL database), and choose to delete one of the duplicate records in question. See support document www.silentpartner.com/support/sup114.doc or contact Silent Partner for assistance, modifying your WinSales database using Microsoft Access can be very damaging.

Fixing non-Y2K compliant values: The conversion program will evaluate all values associated with fields that are a data type of DATE as well as all timestamp values stored in the database.  If the value is found to be prior to 1920 then the program will add one hundred years to the value.  For example a call scheduled for 1902 would be updated to 2002.

Cleanup multiple responses for single response fields: In prior versions of WinSales it was possible to have more then one response associated with a single response field.  This was could occur if a field at one time had the multiple responses option turned on, and it was turned off at a later point leaving the multiple responses orphaned in the database.  Turning ON this option in the conversion program on will remove the other responses that are still in the database.  When faced with multiple responses associated with a single response field WinSales will keep the value with the most recent time stamp (most recently saved value).

Update TEXT data type fields with the former maximum length of 40 characters to 65 characters: WinSales 5.0 now allows a text field to have a default maximum length of 65 characters.  In WinSales 4.0 the maximum length of a text response was limited to 40 characters.  This option will update all existing TEXT data type fields that have a maximum length of 40 to 65 so new responses can be entered up to 65 characters in length.  This will make the database slightly larger as we store the extra 25 characters in the database.

Delete all activities NOT associated with a contact? The conversion program allows you to easily delete activities that are not associated with a contact.  These are usually activities scheduled through the WinSales calendar for Sales Reps where the activities are not linked to a contact, so the activity is for the sales rep.
Delete all activities older then ______: The conversion program allows you to easily purge old data that you no longer need in your WinSales database.

Convert current WINSALES.INI to System Registry: The WinSales 5.0 program no longer has a WINSALES.INI to store many of the machine specific information like the Connect To Database list and form settings for where windows appear.  If you are running the conversion on a machine where you use WinSales you can select this option for the conversion to update your registry settings.  Once you have converted a database on a machine this will automatically un-select unless you force the program to recreate the registry settings.  If you don’t run the conversion on a machine the first time you start WinSales 5.0 and log into a 5.0 database the registry settings will be created using the system default settings.

Top ten fields description name and column heading are hard coded because of issues with the internal search engine for WinSales and the Trigger Language needing these specific values to be unchanged by users to work properly.

CalMonth Trigger Function: The conversion program will now convert all triggers with "CHR$(44)" to CHR$(21) with some hard coded exceptions (like the Meeting3 trigger)…  This means in triggers where there were coded list for months so they sorted correctly "Jan,Feb,Mar” to CALMONTHS() with the proper delimiter.

Blank field descriptions updated to <Attr Name> by the conversion program, as null values are no longer valid field descriptions.  Use the WinSales Administrator to update the field descriptions.

The DB LIB functions have been removed from the Trigger Language, as there was no direct conversion that could be used in the conversion program to update the triggers.  If users have triggers that have DB LIB command in them you will see messages in the conversion LOG file that says, "The WinSales Conversion Program found an outdated trigger language element. Some trigger functionality might have been lost.  Please contact Silent Partner for further instructions."  If you have any of these messages in your conversion log please contact Silent Partner.

WinSales 5.0 uses OLE DB and ADO to talk to the database.  OLE DB is designed to provide universal access to several relational and non-relational data sources.  WinSales communicates with OLE DB using Active Data Objects (ADO). By using ADO in conjunction with OLE DB WinSales can talk to Access, SQL Server, and potentially Oracle (in development), or any other data source by simply using the ADO object model.

User Settings removed by the 5.0 conversion that are no longer in the WinSales program: SQLMaxConnect, WordVersion WPVersion, WPPreferences, WordPerfectPath, DDETimeOut, IncidentTracking, ImagePath, DashboardPAth, AmiProPath, AmiProTemplate, UserTrainingPath, SearchResultIncement, MaxForegroundResults, MaxBackgroundResults, LockDelay, MSWriteTemplate, ImagePath, and all WinSales Dialer settings are now controlled by the machines windows settings.

User Settings added by the 5.0 Conversion program: QueryGridFontSize, ActLogGridFontSize, IgnoreTriggerErrors, AlarmTaskAttribute, TaskListSortColumn, TaskListSortOrder, ApptColWidths, DefRemindTime, ReportsDB, GraphPath.  See the appropriate module area of the release notes for specific definition of new user settings.
The ImagePath setting has been removed by the conversion program and images are always looked for in the <application path>\Images\ directory.  Triggers that call images from other locations will need to be updated so the images appear correctly. 
Wizard screens with no set size will be centered at a size of 4500 twips high by 7000 twips wide.  The conversion program updates Triggers with [Wizard].Command = "Page" + "<crlf> to be centered.

Trigger Language code updates all triggers where a list separator of  comma (",") was used to be CHR$(21).  The effected trigger elements are the [xxx].List for "COMBO", "LIST", and "DROPDOWN".  The WinSales Trigger Language is using a CHR$(21) as the new delimiter.  When the conversion program modifies any part of a trigger it will always add the commented line, “'IMPORTANT:LINE BELOW MODIFIED BY V5 CONVERSION PROGRAM!!!!”, then the old line of trigger code will be commented out, followed by the updated line of trigger code that the conversion program added.  It is possible when update triggers to cause lists coded with comma delimiter to not display correctly.  Triggers need to be updated using the WinSales Administrator to use the new CHR$(21) delimiter to fix the problem.  For example:

Before: [Local].List = "Schedule Phone Call,Schedule Tour

After: [Local].Lst = "Schedule Phone Call” & Chr$(21) & “Schedule Tour”

Please call Silent Partner for assistance on issues regarding WinSales Triggers after converting to WinSales 5.0.

CUST records removed from database where the CustID (customer) no longer exists in the database.  This standard database integrity check verifies every CUST (fields below top ten on contact) have a valid CUSTOMER record CustID corresponding, and if it does not find a valid CustID the CUST record is removed.

ACTIVITY records where no ClassID or CustID exist are removed.  This standard database integrity check verifies every ACTIVITY record in your database has a valid class (type of activity).  This ensures if activities were deleted orphaning activity records they will be removed on conversion.

Custom response values associated with fields with a drop down list only will have the responses added to the drop down list.  If the custom response value is not in the list it will be added and administrators can remove the items from the list and deleting the corresponding data through the WinSales 5.0 Administrator. 

The conversion utility renames the HelpWizardMenu to ToolsWizardMenu and HelpUserWizard to ToolsUserWizard.  In the conversion the above triggers are renamed as the wizards in WinSales have now moved under the Tools menu item under Wizards and Administrator and User.

WinSales Licensing

To view a WinSales 5.0 database license log into WinSales Administrator and select License Options from the Help menu.

WinSales licenses the number of concurrent users that can be logged into a database.  Microsoft Access and SQL Server databases follow the maximum number of concurrent users rule.  Users of Terminal Server follow the same rule with concurrent users counted as users logged in through client machines to the database on the Terminal Server.

Users logging into multiple sessions of a WinSales database as different WinSales users from the same client machine count as separate users in licensing.  Even though the two WinSales users are logging in through the same client machine they are counted as separate WinSales users.  One WinSales user at a client machine may open as many modules of the program as that one WinSales user and will not be counted against the total number of users logged into the database.

WinSales licenses the number of remote database sites that may be created through the WinSales Administrator.

WinSales tracks the number of users associated with each remote site in synchronization architectures and enforces the maximum number of concurrent users for each site as the number of users set in the Administrator for this site.  Microsoft Access and SQL Server databases follow the maximum number of concurrent users rule.  Users of Terminal Server follow the same rule counting each client machine as a WinSales user.

Message at log in that “License Key found to be corrupted. Reset?” The license key in the WinSales database can potentially be corrupted and if that is the case the program will give the user the above message at log in and not allow access to the database, though other WinSales databases on the machine will work. Users best course of action is to select YES to reset the license key and log into the database in the WinSales Administrator and go License Options on the Help menu and select EXPORT LICENSE FILE which will create a new WSL for your database in the local WINSALES folder where the program is installed. Email the WSL file to support@silentpartner.com and explain the situation. A Silent Partner technical support representative will follow up with you. The database will need to be re-licensed by Silent Partner. Until you receive the new WSL file from Silent Partner to LOAD in through the License Options area the database is license as an evaluation copy and you will not be able to save additional data with more then twenty contacts.

WinSales Program

The Connect To Database drop down list of databases to log into the database is now stored in the registry settings for the user.  To remove items from the list log into the database you wish to remove in the WinSales Administrator and select DELETE from the FILE menu. To modify names in the list log into the database whose name you wish to modify in the WinSales Administrator and select RENAME from the FILE menu.

The WinSales quote of the day at log in has been removed, someday we hope to bring this back as a feature where customers can define their own quotes that the program called.

Users logging into multiple sessions of a WinSales database as different WinSales users from the same client machine count as separate users in licensing.  Even though the two WinSales users are logging in through the same client machine they are counted as separate WinSales users.  One WinSales user at a client machine may open as many modules of the program as that one WinSales user and will not be counted against the total number of users logged into the database.

Users may change their WinSales password within WinSales using the Options menu and selecting Current Password from the Modify menu. For users working with SQL Server databases this feature will update the users SQL Server Log In password if the user has the privileges to change their password in SQL Server (even if their database is an access remote database running synchronization with a SQL Server master database).

WinSales tracks the Campaign for a user and database in the registry settings.  When users connect to a database for the first time WinSales will ask select a Campaign to set as the default Campaign for the user in this database when logging the first activity for a contact.  Each database a user connects to will be tracked separately and can be changed by the user under the Options menu by selecting Active Campaign from the Modify menu.

Change the active Sales Rep in WinSales by selecting the OPTIONS menu and choosing MODIFY ACTIVE and SALES REP and choosing from the list of Sales Reps from the reference table.  New activities in WinSales will have this Sales Rep name defaulted.

Change the active Campaign in WinSales by selecting the OPTIONS menu and choosing MODIFY ACTIVE and CAMPAIGN and choosing from the list of Campaigns from the reference table.  New activities in WinSales where contacts have no activity history will have this Campaign name defaulted.

New shortcuts in the WinSales program to help users more easily access heavily used areas of the program: F5 – Refresh (for Calendar and Workbench only), F7 – Activity Log Filter, F9 – Import, and F12 – Internet (a search based on search engine defined in User Settings) or Shift F12 which just opens the browser.

New shortcuts in the WinSales program for Print and New, Next and Previous shortcuts removed. In WinSales Control + P is the shortcut for PRINT. Control + N is the shortcut for NEW.  The shortcuts for the Next and Previous buttons have been removed (the buttons in the lower left serve this function).

The Tools menu in WinSales has been added to allow easy access to commonly used program modules.  From the Tools menu users can choose the module they wish to log in to and by doing so launch the Administrator, Fulfillment Center, Synchronization, Alarms, Report Database, Palm Sync, or Wizards allows access to Administrator or User wizards that are defined for the database.

To access the Internet within WinSales users have hot keys F12 – Internet (a search based on search engine defined in User Settings) or Shift F12 which just opens the browser.

From Send Email on the File menu choose WinSales for MAPI email or Outlook for CDO email form. The WinSales choice with a MAPI compliant messaging system allows users to log the email in WinSales as an activity. Sending WinSales via Outlook and the CDO interface does not give the WinSales software the ability to log the email as Outlook does not allow programs to easily access email once sent because of risks of programs like viruses of malicious intent.

Use WinSales selection from the Send Email choice on the File menu to send internet email using a MAPI complaint messaging system. Set the Contact email address field by selecting Modify from the Options menu and User Settings.  On the Contact tab select the EmailAddressAttribute setting and select the field in your database where you store contact email addresses in the New Setting drop down list.  This will allow WinSales to populate the Contact’s email address in the email form for the user.  Use the Administrator to select a WinSales Activity to log sent email from the File menu.  WinSales will automatically log the email with the associated contact as a resolved activity of that type on the current data and time for the sales rep logged into the database with the notes of the activity being the text of the email message.

Access the Silent Partner support page through the Help menu and selecting Product Support. Find technical documents and downloads to help you make better use of WinSales.

The SAVE ALL option on the Edit Record menu saves all data on all displayed forms and clears the Contact, Activity, and Reference Table window if they are open, while leaving the Workbench and Import windows populated. 

Active field selected description is blue and the value is bolded.  Once the user selects another field that field updates to be active and the previously selected field reverts back to its normal font.

The duplicate detection form that displays when a duplicate contact is entered is now resizable.  Once the user sees this window the form can be resized for easier viewing of the records in question.

WinSales Dialer now opens the Microsoft (R) Phone Dialer for use with modems and TAPI compliant phone system software.  For further information on the Microsoft (R) Phone Dialer see www.microsoft.com.

All WinSales note containers (Contact, Activity, and Reference Tables) have expanded note capacity with the maximum length of a note now 2gb of data!  The pasting of formatted text as well as images and files are supported now, but at this time cannot be saved.

When updating contact address and phone information where multiple contacts are at the company WinSales will display message 190 if the any of the other contacts have the same value in that field so you can update their records’ value for that field too.  Other contacts at the company with a different value (direct dial phone numbers for example) will not be updated.

There is a twenty six field criteria limit when searching for records in WinSales. This limit pertains to searches directly on a window or through the Workbench.  Searches using more then twenty-six fields will receive a Query To Complex message. 

Windows undo shortcut Control + Z works in WinSales text response and note containers. This feature will undo modifications, but will not undo a saved change to the database.
Activity Log Modifications:

Hot key of F7 added to pull Activity Log Search Filter.  In WinSales to open the Activity Log Filter found on the Search menu under Activity Log users may now simply use the F7 key on the keyboard.

The Activity Log will not allow a record in the grid to be selected until all records are retrieved.  To increase the speed or retrieval check the User Setting Tuning.MaxRetrieve.  The higher the value the more records are retrieved and the longer the searches take.

When printing activities in WinSales from the File menu (or Control + P) the Company name as well as the Contact name are printed. 

New User Settings to control the Font properties (color/size/type) of the Activity Log grid are located in User Settings on the General tab. ActLogGridFontSize may be set to 8 point and higher, colors and styles available are based on the machine. Select the ActLogGridFontSize and click the FONTS button in User Settings, select the Set Fonts For choice and make your modifications and all settings for color/size/type will populate in the user settings.

Reference Table Modifications:

The number of records that can be in a reference table and linked to using a field defined as a Reference To A Table has been increased to thirty two thousand records.  With more then thirty two thousand records in the reference table the link will not work causing WinSales to stop responding properly.  Anytime a linked table has more then a thousand records created the Reference To A Table drop down list the performance will suffer as the program needs to build that list.  The more records in the table the longer it takes to build the list – fast machines and SQL Server databases increase performance dramatically. Unlimited numbers of records can be contained in a reference table and used with the WinSales Trigger Language to access and manipulate the data.
Calendar Modifications:

Users can refresh the WinSales calendar using the F5 key on any of the calendar tabs to see new data that has been scheduled for the sales rep logged in. 
Task List columns can be sorted ascending by clicking (or control + clicking for descending order) to column heading.  This allows easy access to many views in the calendar for easier use.

Activity TYPE added to the Task List as a column.  Users can click (or Control + click) the column heading to sort the Task List by the activity type column.

Activity time added to the date column in the Task List. Users can click (or Control + click) the column heading to sort the Task List by the activities date and time.

The Task Cancelled and Task Finished buttons on the Calendar have been removed from the Task List. This feature of 4.0 caused problems for users working with WinSales Triggers because activities resolved through the calendar did not fire triggers.  This has been resolved by removing that capability from WinSales.

Required fields when creating activities through the Calendar: When creating a new activity through the WinSales calendar users will now be able to fill out all required fields for that activity.  When clicking OK to save the new activity a window displaying any other required fields on the activity will display with the appropriate drop down lists for users to select from.  

When creating a new activity through the Calendar if there is not a contact on the Contact window the “For Contact” Calendar option on the New Appointment and New Task will be disabled.  Since there is no contact active this option is not available.  Once a contact is populated on the Contact window users can create activities through the Calendar by select a time slot that hasn’t been taken on the Appointment and Planner tabs, or on the Task List selecting the NEW button in the lower right corner.
Control clicking on an item in the planner displays the contact name and the beginning of the note for the activity in the messages area in the lower left corner.   Users may find this helpful in checking schedules in a weekly view where the contact’s name is not displayed in the calendar view.
The column widths on the Appointment tab are stored by the ApptColWidths Calendar User Setting.  When switching tabs or closing and reopening the calendar users can set the display as they wish and the program will remember.  The multiple columns in the user setting are used when activities are overlapping in a time frame.  Users do not need to manually update this setting.

The TaskListSortColumn User Setting saves display options in the Task list area of the Calendar so the view is the same the next time the Task list is opened.  The setting is updated whenever a user sorts the Task list by selecting a column heading.  WinSales saves that column as the default Task sort column so when the calendar is closed and reopened that will be the view that is displayed.

Printing the Calendar from the File menu allows only the view you are working with.  On the Appointment and Planner tabs you may print your daily and weekly planner views, but the Task List is disabled.  On the Task List the daily and weekly planner views are disabled.

When creating activities through the WinSales Calendar the Campaign field on activities must be required to force activities to prompt for a Campaign on the creation of an activity. If the Campaign field is not required on the activity the activity records created through the Calendar will not have a Campaign value. 

Action Plan Modifications:

Updating Action Plan step names checks WinSales Triggers to ensure the step name is not used in triggers.   If the step name is used in trigger users will be forced to update the trigger before update the step name will be allowed.  The reason for this is renamed Action Plans break WinSales Triggers and cause databases not to function properly.

Import Modifications:
F9 is the hot key for the Import form in WinSales 5.0.

Option to view the error file after the data integrity check has completed.  When processing an import in WinSales users will now have the options after the data integrity to view the error file (.ERR) file created in the directory of the file being imported, if yes is selected the file will be displayed in Notepad for review and further modification to the source CSV file before processing the import again.

Selecting the Backup Database First option the program forces the selection of the Exclusive Use option as well as it must have exclusive use to make the backup.  When the user clicks PROCESS the program will ask for the backup file’s name and location, then copy the database (%bar at the bottom), and then run the Data Integrity check allowing you the option to proceed or stop the import as usual. 

The option of “~” has been added as a Record Separator choice in the drop down list.  When importing notes many users add a last column to their file with a “~” value and use that as a record separator in the import as using a carriage return or carriage return line feed does not work well with notes and throws off the field mapping.

Import multiple fields from your Import file into a WinSales Multiple Response field by mapping the different FROM fields to the same WinSales Element so that it is listed multiple times in the TO list.  

Column Headings added to the reject file with Imports.  When importing records if there are any rejected in the *.REJ file the file with have the field column headings included for easier viewing and importing if necessary.
Workbench Modifications:
New User Settings to control the Font properties (color/size/type) of the Workbench query grid are located in User Settings on the General tab. QueryGridFontSize may be set to 8 point and higher, colors and styles available are based on the machine. Select the QueryGridFontSize and click the FONTS button in User Settings, select the Set Fonts For choice and make your modifications and all settings for color/size/type will populate in the user settings.

Copy Grid Data To Clipboard option added to menu on right click of query grid.  To copy the grid to Excel select any place on the grid and right click and select the Copy Grid Data To Clipboard option. Open Excel and paste the grid information with a Control + V and format in Excel as needed.

For information on the Mail Merge workbench function which deals with the merging of data from WinSales to Microsoft Word, look in the Fulfillment Center section of the Release Notes. The Fulfillment Center is the other area of the program where WinSales merges data to Microsoft Word.

Send keys will run Workbench functions.  Users may work with different scheduling products to run WinSales Workbench functions like exports that will be data sources for reports.  The Send Keys to run a query for example are: F4 (to open), Tab (selects Query), Enter (opens the list of Queries), Right Arrow (selects New Query, first item in list), Down Arrow (move through the list), Tab, Tab, Tab (selects Use on Workbench tab), Back Arrow (selects Results tab), Enter (runs Workbench function).

When sorting by a Reference Table field the field does not have to be included in the grid.  For instance when finding activities and sorting by campaign.total cost the total cost field does not have to be included as a field in the grid. WinSales can use the created link to the table through the criteria to find and sort the data properly. 

Workbench function of Mobile Device Configuration added for the creation of mobile devices.  When creating the mobile device database for a device site the user will come here to the Workbench and build the criteria for the information to be in the mobile device database. Users will need to have their database licensed for use with Mobile Device sites for this portion of the program to function. Contact Silent Partner regarding purchasing Mobile Device sites.

Wizard Modifications:

The hot key to Wizards in the WinSales program has changed from F5 to F11 for Administrator wizards and Shift + F11 for User wizards.  If the user logged in has security to navigate to the Administrator Wizards on the Tools menu then when selecting F11 the Administrator Wizards will open, clicking Shift + F11 will open the User Wizards if security is enabled.  If the user is not in a security group enabled to use the Wizards the window will not open.

Administrator and User wizards may now be accessed under the Tools menu in WinSales.  Wizards are developed by Silent Partner to assist users in working with their data.  The Administrator wizards are found in all WinSales databases while User wizards are customized to the database by Silent Partner, or customers with the WinSales Trigger Language, to further automate tasks in the database.  

Administrator and User menu items under Wizards can be secured against users using WinSales Security Groups through the Administrator.  Some groups need access to this area and others do not.  Major changes are possible using these Wizards and only qualified users or WinSales Administrators should be allowed access.

Administrator Wizards in the database have been expanded to allow up to three field criteria’s in search selection for Mass Update, Mass Delete, and Delete Multiple Contacts and their Activities through the Tools menu in WinSales.  Use the wizards to assist in making changes to your data. The additional criteria capabilities increases the flexibility administrators have to work with records in the database.

The Mass Delete Administrator Wizard does not allow Contact deletes.  To delete Contacts use the Delete Contact and Activities Administrator Wizard. 

The Delete Contacts and All Activities Administrator Wizard enables users to delete multiple contacts and all their activities.  This allows administrators to search for contacts using a three criteria Contact field search to find the records, and then the wizard deletes the contact records and all activities associated with the contacts.  This allows deletion of all contacts set to a DELETE status and easy removal of the activity records.

The Mass Update Administrator wizard now allows the update of the Status field on Activities and will update Action Plans accordingly.  Administrators who wish to resolve a group of activities that are part of an Action Plan may do so using Mass Update and the next step in the Action Plan will be scheduled for the contact.

Administrator Program

To view what your database is licensed for log into WinSales Administrator and choose License Options from the Help menu.  For information on re-licensing your database see SUP101.DOC under the topic of Licensing.  This area may be disabled using WinSales Security Groups to keep users locked out of the License Options area.

Form placement is remembered so moving a window and closing will now save that position unless the window is set to be centered.  All child windows in Administrator that aren’t centered can be moved and when closed will remember their position.

The maximum length when creating new activities and tables in WinSales 5.0 is 30 characters.  The description (what displays in WinSales) can be up to 40 characters in length.  Existing table names that are eight characters and under (the 4.0 limit) may be modified using Microsoft Access 2000, but unless you are using your database for purposes outside of WinSales this should not be necessary as the Table Names are rarely seen by the user in WinSales.

The maximum length of the State field on Contact has been expanded to allow up to 65 characters.  Customers will need to update this through the WinSales Administrator after converting to 5.0.  Be aware if using the Contact.CheckState user setting feature WinSales will check that the State value entered by the user exists in the State table as a valid Postal Code.
The Area Code reference table is no longer required in the WinSales database.  In previous versions of WinSales the Area Code table was hard coded into the product and could not be removed by customers.  That is no longer the case in 5.0 and if you wish to remove the Area Code table you may.  If you have current trigger programming using the Area Code table to confirm states or zip codes you can leave the table as is, but with the updates required to keep that data current we find our customers do not use that table and most would like to remove it.

Deleting a Reference Table or Activity used in WinSales Triggers generates a warning message telling the user what trigger is calling this class (usually triggers are tied to fields on the activity or table to be deleted).  Users have the option to proceed with the delete or stop at that point and modify the trigger noted in the message.  Once the trigger has had the reference to the activity or table removed users should attempt to delete again and see if there are other triggers attached.  Only one trigger can be listed in the message so even though one is listed there may be many other triggers where this activity or table is used.  Beware, deleting activities and tables where triggers are attached can cause serious corruption to your database!!!

When deleting an Activity the program checks if the activity is used in Action Plans and allows the user to abort the delete.  If the program finds that you have Actions Plan where the activity is in use, it asks you if you want to proceed.  If the user says OK then the program proceeds to DELETE all the WS_WIP and WS_Step records associated with the activity.  Then the program asks the user if they "really" want to delete the activity.  If the user says no, message 1059 shows the WIP and Step records are already gone (which keep track of all the Action Plan information – what steps are the activity type and what contacts were on a plan with that type of activity).

Setting the activity to log EMAIL as in WinSales.  In WinSales Administrator under EDIT + DATABASE SETTINGS users can set the Activity for emails that are sent using the FILE + SEND EMAIL option to be logged as resolved activities of that type with the body of the email in the notes area.  Remember to set the User Settings for General.UseEmail to 1 and Contact.EmailAddressAttribute to the field on contact used for storing the email address for each WinSales user.

Database maintenance Optimize and Compact routines combined.  All Microsoft Access databases need periodic maintenance.  WinSales 4.0 separate Optimize and Compact menu items have been combined as the process calls Access 2000’s repair and compact process.  This will create a backup copy of database from right before the database maintenance with a name of DATABASE_NAME.1.  Remember to delete the old copies of these files as they can take up disk space, especially if you have a large database.  We recommend backing up your database to tape for best security against disaster.

TEXT data type field’s maximum length of 65 characters is now available for expanded capacity.  The WinSales 5.0 conversion has an option users can select to update all existing TEXT data type fields that have a maximum length of 40 to 65 so new responses can be entered up to 65 characters in length.  Users should remember having long maximum field lengths makes the database larger as WinSales stores the maximum field length, not just the data entered.  For best performance use WinSales Administrator to adjust field’s maximum length to be sized appropriately with the responses that will be entered.

Column Headings required and now default to Description when entering new fields through WinSales Administrator.  When you enter a Description (the value that shows up in WinSales) and tab out of the field the Column Heading is automatically populated with the same value.  This is to avoid confusion with mail merge header files and other areas where column headings count.  You must enter a Column Heading, and though the default populates the same as description you can change the value.

Deleting Multiple Response field will give users a warning message that are about to delete all “multiple” responses, and if yes is selected by the user that most recent entry is saved where there are multiple responses, and the other responses are removed from the database.

User Names can be different then the Sales Rep in WinSales 5.0.  When adding or update an existing user through EDIT + USERS the Create a Sales Rep (for New User) or the Link to Sales Rep (when selecting existing users) should be selected, unless you are adding a user that you do not wish to have a Sales Rep record in WinSales.  Once you have updated or added the user go into WinSales and open the Sales Rep Reference Table through the VIEW menu and find the Sales Rep name (which will be updated to the USER name).  Change the name there to what you wish the Sales Rep name to display in WinSales.  Now when you look at the User in Administrator you’ll see User JE is associated with Sales Rep Janet Evergreen.

When creating a new user that user’s User Settings will be inherited from the user logged into Administrator.  When creating new users the settings that are associated with that new user will be the user logged into the Administrator.

User Settings in Administrator has option to Update Setting For All Users when making modifications to a users settings.  When changing a setting through Administrator only a check box is available to select which when users save will update all users User Setting to reflect the change.

Creating new WinSales Users in a SQL Server WinSales database through WinSales Administrator require the SQL Server Log In associated with the user logged in to the WinSales Administrator be set up as a SQL Server Role of System Administrator so that SQL Server will allow the new WinSales Users to be created correctly in SQL Server.

When creating New Activities and Tables in a SQL Server WinSales database using WinSales Administrator the security must be set up correctly to work with the SQL Server.  In SQL Server Enterprise Manager check the LOG IN (in Security) properties and on the ROLES tab be sure that the LOG IN has a ROLE of SYSTEM ADMINISTRATOR if you want them to successfully be able to create new Activities and Tables in WinSales.  For more information on this review support document SUP099.DOC on creating new activities and tables in a SQL Server database.

To convert a WinSales 5.0 Access database that has been licensed for use with SQL Server use SQL Server Enterprise Manager to import the Access 2000 database to a new SQL Server database using the Data Transformation Services wizard.  Once the database has been imported into SQL Server start the WinSales Administrator and click CANCEL at the Connect To Database window.  Select the FILE menu and choose REBUILD SQL INDEXES from the menu and fill out the SQL Server questions regarding the Server name, the Database, and the User and Password for the database.  Upon clicking the BUILD INDEXES button the program rebuilding the indexes for the database in SQL Server.  This can be used as a conversion tool as well as a database maintenance tool for WinSales Administrators with WinSales SQL Server databases to maintain.  Once complete if you have a database that is licensed for SQL Server with WinSales you can connect to it through the Connect To Database window by typing in a new database name with a database type of SQL Server.

The structure of the Tailored Selling System database that you downloaded is stored in a Microsoft Excel file format in the WinSales folder where you installed the software. You can use this database structure to see all of the activities and tables in the database along with every field and drop down list in the database. This database structure is the start of every new database and modifications to that structure may be sent to Silent Partner using the WinSales Issue Report.Doc installed in the WinSales folder where you installed the software.

WinSales Security Groups:

The Remote Administrator program is no longer installed with the main WinSales installation package for security purposes. With the power of the Remote Administrator module in mind the WinSales 5.0 Remote Administrator program module is not installed, but is still available from Silent Partner by request from customers WinSales Administrators who have need of the program. This tool allows users to completely by pass normal WinSales Security Group privileges and enable everything in the database.

To disable a security group from being able to save items in WinSales the group must have three things disabled: 1) The “Save” Edit menu Item 2) The “Save All” Edit menu item 3) The “Save” button on the form.  If any of the above are enabled, then security will allow the save of data.

Control of all program modules log in through WinSales Security Groups.  In WinSales Administrator all the program modules for WinSales have been added as Security Group options for each group that Administrators can grant or remove ask to certain modules for certain groups.  For examples user groups who wouldn’t ever need access to Synchronization or the Administrator can have that removed and when they attempt to log in to the module they will be blocked.

Contact table must be enabled under Table Security.  In Table Security you are not allowed to remove Contact from the list.  You may select the Contact table and go to Field Security and affect what fields are enabled for Security Groups.

Remote Synchronization:

Tracking the number of remote sites and users in a database.  Each WinSales database is licensed to have a specific number of remote sites for users to work remotely synchronizing with the master database.  In WinSales Administrator under EDIT + SITES each site is defined with a number of remote WinSales users. Users cannot create more remote SITES then the database is licensed for (Help + LICENSE OPTIONS).  The number of users at each site is tracked so that the maximum number of users at all sites cannot exceed the number of users the database is license for.

When creating remote sites 4 character short names are required.  If you modify an existing site from v4.0 that has a three character short name you will be forced to update that short name to 4 characters.  Changing the short name will require you to recreate the remote database.  If you are using NetSync through email the User Settings for the master and remote site’s sync user will need to be updated reflect the 4 character short name using the EDITOR tab in Administrator’s EDIT + USER SETTING area.  We recommend if you have 3 character short names with sites in 4.0 that you update them to 4 characters now after converting the master database.  Then modify the short names in the User Settings and recreate the remote site databases.

Duplicate site short names are not allowed.  When creating remote sites users may not have duplicate short names.  Users in WinSales 4.0 who had existing duplicate short names in sites we recommend you make them unique.  The conversion program could not make these updates, but next time the site is changed the duplicate short name will have to be dealt with.  Using duplicate short names could cause some synchronization features not to work properly.

Un-checking the Synchronize with Model check box when creating a remote site database creates a new database with a demo license number.  The Synchronize with Model check box should only be unchecked if you wish to create a structural shell of the database with no information in the file.  This database could then be relicensed through Silent Partner with the appropriate license number for the customer.

In synchronization through the Administrator users can control the date data is extracted since.  If users need to “set the date back” for synchronization to pull all of the changes in a database since a date this can now be done through WinSales Administrator.  Log into Administrator as a user who is associated with this site and going to the File + Synchronization + Extract and changing the date displayed to the date you want to pull change since.

Rep-specific sites may be created while users are logged into the database.  In WinSales 5.0 when users are creating a database for a rep-specific site you no longer need exclusive use to the database.  When creating All Rep (full copy) remote databases you will still need all users logged out of the database file.

Sites with blank Extract To dates are ignored in synchronization.  In WinSales 5.0 when synchronization sees a site with a blank Extract To date the site is skipped and no synchronization file is created for that site, and the blank Extract To has no affect on the program.

WinSales 5.0 Trigger Language Modifications:

The maximum size of a WinSales Trigger is now 400 lines and two gigabits, creating larger triggers will generate errors requiring you to shorten the text.  Blank lines are not counted, but comments are.
Search functionality added to WinSales Triggers.  There is now a search button for triggers.  The following rules apply: 1) Selected text will auto load that into the search. 2) Searches from that point to the end of the trigger (down), if no text is selected it will not have any default text and it will start the search from the beginning of the trigger. 3) If the text is found it will move the selection to that text, additional "searches" will find the next occurrence of the selected text. 4) The search will not Move to the next trigger.

[SYSTEM].Edition trigger element is no longer valid.  This was used to return the WinSales License Edition (Network or Professional) which is no longer valid in the WinSales 5.0 license design.

Wizard background color control added to the Trigger Language so the wizard windows can now be set to a color rather then the Windows color scheme selected.  This function works as the foreground color does.

The ImagePath setting has been removed by the conversion program and images are always looked for in the <application path>\Images\ directory.  Triggers that call images from other locations will need to be updated so the images appear correctly. 
Tuning.IgnoreTriggerErrors User Setting created and should be set to 1 to disable trigger errors that may be displayed in WinSales 5.0 that were not seen in WinSales 4.0 because of changes to the Trigger Language.  This User Setting has been created and defaulted to 1 in the conversion program.

Changes to the WSSQLCONNECT statements include a) The name to be any length. b) no connections are actually made to the SQL Server database, however, this doesn’t mean you can't "run out of slots", there are 100 "slots" available. This means that you can have 100 concurrent SQL Record sets open at once, now you think, "we'll never" get there, Yes you will if you don't head the warning about "disconnecting" once your completed. So, disconnecting is important, otherwise it will open a slot every time you call the line. d) If a slot "name" is reused before it is disconnected, you will get the "handle" of the existing one and the old result set will be cleared. e) Slots will be (internally) reused, the "slot" array grows but never shrinks, f) [LOCAL].DB & [GLOBAL] SHOULD STAY IN SCOPE....Thus "global" connections are Allowed!

Default centering of wizard screens through use of –1 for height and width in positioning command.  Use the command:

[Wizard].Command = "Page(-1,-1,4500,8000) 1"

in setting up the wizard screen in the trigger to center the screen.

Fulfillment Center Program

WinSales knows where Microsoft Word is through the registry settings for the computer.   This means there is no longer a WordPath User Setting to keep track of where the program exists, if your machine is set up properly WinSales should find Word automatically.  You just have to set up your letters correctly and tell WinSales where they are located, along with the appropriate header file.

WinSales 5.0 does not support Word Perfect or Amipro for word processing.   

WinSales 5.0 works with Microsoft Word 97 and higher (WinSales no longer supports mail merge with Microsoft Word version 2.0 or 6.0).

User Settings can be accessed through the Options menu where users can change any of the User Settings for the user they are logged in as without reloading the program or logging into Administrator or the main WinSales module to fix FormLetterPath or other setting issues with Word Processing.

Insert Column in the Fulfillment Center grid for balancing letters.  Users can click anywhere on the grid and insert a new column (date) forward from the cell they are on, you can’t create a column in the past.  When you select Insert Column a calendar window will pop up to select the date and when you click OK the new column will be added.  Users may then drag across cells to balance letters for printing.

WinSales will now merge and send emails with HTML files using WinSales and the Fulfillment Center.  Users can create an HTML file from a Microsoft Word form letter by saving the document as an HTML type file and mofifying the HTML file as desired. When you are in Fulfillment Center and have the user set up to merge and send emails properly and the HTML file is in the user’s FormLetterPath WinSales will merge and email the HMTL file to the contact. Users cannot have a TEXT file and an HTML file in the FormLetterPath, one or the other needs to be there for WinSales to work, if both are the program will not work correctly.

Synchronization Program

For more information on Synchronization see the Administrator section of the Release Notes on synchronization.

Synchronization will not run with an invalid SyncPath User Setting.  When a user runs the synchronization program with an invalid SyncPath setting the program will skip synchronization not allowing the export of data.  The LastExtract sync date is not updated when this happens.

ReportDB Program

The ReportDB program is a licensable feature of the WinSales program.  If a users database is not licensed for the program it will not log in to the database and will give you the appropriate licensing message.  If users wish to evaluate the tool they may run the ReportDB program on any of the demonstration databases provided by Silent Partner, or existing customers may call Silent Partner for temporary licensing to evaluate the program.

In the WinSales ReportDB.EXE the default file name of the database created by the program is the name of the WinSales database logged into (.WSD) with _Report.MDB file extension.  For example if your database file was SILENTPARTNER.WSD the ReportDB program default file name is SILENTPARTNER_REPORT.MDB.  Users can change the default file name to anything they want *.MDB and run the program.  For the reports included with the Tailored Selling System the file name for the reports defaults to the name of the Training WSD file, but with a MDB extension. Users would need to call their ReportDB output MDB file the Training database MDB name to run the reports on the source file with your databases information. To modify the reports so they pull from your WinSales database name .MDB you would need to purchase Crystal Reports and modify the reports data source file.

Security: Since the Program enforces Winsales Table and field security, you must log into a user account that has access to all of the fields. Any field not accessible though standard security will not appear in the report database.

Column Creation: WSREPORTDB created Column Name equivalent to the COLUMN NAME Property as seen in the WinSales Administrator.  Additionally, The program will append a "_ID" field to all fields determined to be join fields to other tables. At the beginning of all tables there is an "*_ID" field as the primary key file all tables.

Data type: WinSales field with the Data type "ID" are created in the Program, Generally these field are mirrored in the classes root ID, These field merely create a visible unique number for the purpose of identifying in the mail WinSales module. In some cases, it is also possible that these IDs can become in equal to each other. This does not violate Winsales Database integrity however, because of this, these field cannot be relied upon as id's and are therefore not included. Use the Root record "*_ID" field for all join operations.

Column Names:  Since WinSales does not use these names as real Database columns, certain characters are allowed as WinSales Field names that would not be normally allowed by Access or SQL Server. These characters include "!","@", "#", "$", "%", "^", "&", "*", "(",")". These characters are removed when determining Report Database Fields.

Duplicate Names: With the program filter removing the above-mentioned characters, there is a possibility that the program may attempt to create a duplicate field. For example "Field #1" and "Field 1" will both be calculated as "Field1". In this case, any additional fields are not added and the data not transfer over. The Solutions is to use the WinSales Administrator to be sure that all field names will be unique.

Reserved words: As described above, Report columns are derived from the WinSales column description.  If a filtered column is determined to be an SQL, ADO or ADBC keyword, a "_X" is appended to the field name to prevent a keyword violated when creating the table.

Marketing Details Column: Winsales distributes many Databases with an attribute field that is common to most Activity table. This is the "Marketing details" field. Since this field is contained in most tables, it is included as an Activity table field. Note that this column will be null for those activities whose class type does not contain this field. This field can be used at the users discretion, however do not modify the Column description or the field will be recognized as different field.

Maximum Table length: There is no limited on the number of columns a table can have but you cannot exceed the 8K limit for a record. To reduce single record requirement, the notes data has been put in its own Table.

Notes data are stored in a Binary Object (Blob) field. If the Note exceeds 8K, you must retrieve the note in "chucks".  Consult your report write documentation for instruction on access Binary fields.

Numeric values are not masked on export to the report database; they are the raw value.  For example $50,000.00" will be "50000".  Using the customer’s report writing tool the appropriate mask will need to be applied so the values display properly in reports.

Alarm Program

The Alarm program now shows up in the system tray when open instead of an open program in the start menu area.  Users can right click and EXIT the Alarm program from the system tray.

Only users who are linked to a WinSales Sales Rep can run the WinSales Alarm program since activities are linked to sales reps only.  If a user not linked to a sales rep attempts to log in they will be blocked from opening the program.

The Alarm program window remembers the size and placement of the form on closing of the program.

The TYPE and PRIORITY of the activity from WinSales is displayed in the Alarm program with the same view as the Task list from the Calendar.

The DefRemindTime Calendar User Setting has been added has been added so users can set a default remind time for all activities used in the calendar which allows them to then show up in the WinSales Alarm program the time you entered for DefRemindTime.  When converted to 5.0 this setting is 0 and all existing activities are 0 (unless updated manually in 4.0).  For activities to show up in the alarm program you must fill in a time (in minutes) for this setting.  Existing activities must have the Remind time updated through the Calendar by control clicking on the activity to get to the Appointment or Task window.

The Alarm Finished and Alarm Canceled buttons have been removed and the Dismiss button added to the Alarm program.  The Dismiss button removes the Remind time associated with the WinSales activity so it remains scheduled, but no longer appears in the list of Alarms.

Link to Contact Details button added for users to see the top ten fields from the Contact window in WinSales (plus the user defined AlarmTaskAttribute) when in the Alarm program.  Click the button with the + sign to open the details window about the contact, click the – to close the details window.

AlarmTaskAttribute Calendar User Setting allows you to link one additional Contact field to display when clicking the details button added for users to see Contact information.  The conversion utility added the AlarmTaskAttribute on the Calendar tab, users will need to update through User Settings what Contact field will display.
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